LSPipeline

用户使用手册


1.操作系统环境

本节主要说明支持本系统的操作系统。


1.1 服务器端

Windows操作系统：Windows NT4.0/2000/XP/Vista/Win7等

操作系统位数：32位，64位。


1.2 客户端

Windows 操作系统：Windows NT4.0/2000/XP/Vista/Win7等

操作系统位数：32位，64位。


2.系统部署

本节主要讲的是部署系统需要的一些配置如数据拷贝、IIS安装、服务器授权、客户端配置、服务器配置等等。


2.1 数据拷贝

将系统需要的数据拷贝到服务器中，系统中的数据包括：三维模型数据，影像数据，和数据库文件（pipelinedb）。


2.2 IIS安装

首先需要检查服务器是否安装IIS，如果没有安装IIS环境，需要在服务器上安装（以Windows Server 2008 为例）。

1、 右键“我的电脑”，选择“管理”，打开“服务器管理器”。

2、 点击左边菜单栏“角色”调出角色窗口。

3、 点击“添加角色”，弹出添加“角色向导”。

4、 点击“下一步”进入服务器角色选项。

5、 勾选“Web服务器（IIS）”，弹出是否添加Web服务器（IIS）所需的功能，点击“添加必需的功能”后回到角色向导。

6、 连续点击“下一步”，出现“选择角色服务”时，勾选需要安装的组件，点击“下一步”安装完成。


2.3 数据库安装

安装SQL Server 2005数据库，运行SQL Server 2005安装包，按照安装步骤将数据库安装到服务区中。安装完毕后，运行Sql Server Management Studio，以SQl Server身份验证的方式登录。

登录数据库后，右击“数据库”，点击“附加”，选择管线数据库文件“pipelinedb”，将数据库文件附加到数据库中。


2.4 服务器授权

服务器授权主要是对三维地下管网系统的授权，其中包括LicenseManager、LocaServerManager以及LocaLicenseServer。

1、 运行LicenseManager，将“许可标志码”发给系统供应商，生成系统授权文件，然后点击“浏览”选择生成的授权文件，点击应用。

点击“应用”后，选择“许可支持情况”，即可看到对服务器的授权。

2、 运行LocaLicenseServer，在“服务器设置”中设置端口信息，如：1600，点击“保存设置”，然后“启动服务”

点击“启动服务”后，选择“服务器信息”，查看授权信息

3、 运行LocaServerManager，在“数据管理”中，右击“图层数据”—“添加图层”，将系统中的数据（影像、模型等）添加到该程序中。添加完成后，点击“启动服务”按钮。


2.5 客户端配置

服务器端配置完毕后，需要对客户端的系统软件进行相应的配置，在系统程序目录下查找“FormText.xml”文件和“netlic.cfg”文件，用文本方式打开，对其中的文件进行相应的配置，修改完毕后点击保存。以下图为FormText.xml文件的结构：

<database>(数据库名称)</database>

<dbserver>(数据服务器IP)</dbserver>

<locaserverip>(数据服务器IP)</locaserverip>

<rooturl>http:// (数据服务器IP)/images/</rooturl>

<localicenseserverip>(授权服务器IP) </localicenseserverip>

“netlic.cfg”文件的内容包括：网络授权服务器的ip和端口号，如下图所示：


2.6 服务器配置

参数\服务器 | 应用服务器 | 数据库服务器 | 备份服务器
机柜号 | S10#柜 | S10#柜 | S10#柜
位置 | 机柜从下往上第3台 | 机柜从下往上第4台 | 机柜从下往上第5台
Ip | 10.1.11.106 | 10.1.11.107 | 10.1.11.108
子网掩码 | 255.255.255.248 | 255.255.255.248 | 255.255.255.248
网关 | 10.1.11.105 | 10.1.11.105 | 10.1.11.105
操作系统 | Window server 2008 enterprises 32bit | Window server 2008 enterprises 32bit | Window server 2008 enterprises 32bit
基础软件 | IIS7 | SqlServer2005 | SqlServer2005
 | LocaServerManager | 数据库 | Localicensemanager


3.文件

本节主要讲的是数据的加载，以及数据处理、导出操作，包括打开工程、添加数据、添加数据库图层、添加地形、shp2KML、框选导出图层、lgd和kml合并等等。


3.1 打开工程

“文件”菜单的“打开工程”功能可以添加一个工程（*.gws），一个工程可以包括影像数据（*.lrp）、地形数据（*.gtt）、矢量数据（*.kml,*.lgd）、模型数据（*.kml,*.lgd）等等。

具体操作步骤如下：

单击“文件”—“打开工程”，弹出如下图所示窗体：

选中要打开的工程文件，单击“打开”按钮即可。


3.2 关闭工程

“文件”菜单的“关闭工程”功能可以关闭程序中已经打开的工程（*.gws）。

具体操作步骤如下：

单击“文件”—“关闭工程”，弹出如下图所示窗体：

如果选择“是”，系统会保存用户对打开的工程中的图层所做的修改；如果选择“否”，则不保存；如果选择“取消”，系统不做任何操作。


3.3 保存工程

“文件”菜单的“保存工程”功能可以对系统中已经打开的工程（*.gws）文件中用户所做的修改进行保存。


3.4 另存工程

“文件”菜单的“另存工程”功能可以把系统中已经打开的工程（*.gws）另存为一个工程文件，相当于复制了一个工程文件。

具体操作步骤如下：

单击“文件”—“另存工程”，弹出如下图所示窗体：

填写要另存为的工程文件的名字，单击“保存”按钮即可。


3.5 连接服务器

“文件”菜单的“连接服务器”功能可以连接到服务器所在机器，并把服务器上有的图层添加到本地界面中。

具体操作步骤如下：

单击“文件”—“连接服务器”，弹出如下图所示窗体：

填写要连接的服务器的ip地址、端口号、用户名和密码，单击“确定”按钮即可。

“记住配置”复选框被选中时，单击“确定”按钮后，如果连接到服务器，程序会保存用户输入的内容，下次打开时会直接输入到对应的位置。

如果连接到服务器，并且服务器有数据的话，程序会直接将服务器上的数据加载到本地程序中。


3.6 连接数据库

“文件”菜单的“连接数据库”功能可以连接到sqlserver数据库，如果想添加数据库中的表到程序中，单击“文件”菜单的“添加数据库图层”按钮即可。

具体操作步骤如下：

单击“文件”—“连接数据库”，弹出如下图所示窗体：

填写要连接的服务器的服务器名称、数据库名称、用户名和密码，单击“确定”按钮即可。

“记住配置”复选框被选中时，单击“确定”按钮后，如果连接到数据库，程序会保存用户输入的内容，下次打开时会直接输入到对应的位置。


3.7 添加数据

“文件”菜单的“添加数据”功能可以添加“影像数据”（*.git）、“地形数据”（*.gtt）、“矢量数据”（*.kml,*.lgd）、“模型数据”（*.kml,*.lgd）等。

1、 添加“矢量数据”（*.lgd）,“模型数据”，如下图所示。

2、添加“影像数据”（*.git）、“影像数据”（*.lrp）如下图所示。


3.8 添加数据库图层

该功能主要是添加数据库中的数据到程序中，如果已经连接数据库，直接添加图层就可以；如果没有连接数据库，会提示连接数据库。

具体操作步骤如下：

单击“文件”—“添加数据库图层”，如果没有连接数据库，会弹出如下图所示窗体：

单击“确定”按钮，会弹出连接数据库的窗体，连接到数据库之后，会直接弹出如下图所示窗体：

选中要添加的数据表，单击“添加”按钮即可。


3.9 数据库要素数据集

该功能包含两个子功能，一个是复制要素集，也就是复制数据库中的表；一个是合并数据集，也就是把数据库中具有相同结构的表合并成一个新的表。

复制要素集功能具体操作步骤如下图所示：

单击“文件”—“数据库要素数据集”—“复制要素集”，会弹出如下图所示窗体：

如果要将数据集复制到要素集所在数据库中：

在左侧列表中选中要复制的要素集，在右下角的文本框中输入新要素集的名字，单击“确定”按钮即可。

如果要将数据集复制到其它数据库中：

在左侧列表中选中要复制的要素集，选中右侧复选框“复制到其他数据库”，填写服务器名称、数据库名称、用户名和密码之后，单击“连接”按钮，如果“连接”按钮左侧有“连接成功”的提示，如下图所示：

在右下角的文本框中输入新要素集的名字，单击“确定”按钮即可。

单击“确定”按钮，复制完成之后，窗体会直接关闭；单击“应用”按钮，复制完成之后，窗体不会直接关闭。

合并要素集功能具体操作步骤如下图所示：

单击“文件”—“数据库要素数据集”—“合并要素集”，会弹出如下图所示窗体：

在“请输入新要素集名称”后面的文本框中输入新要素集的名称，在“选择要素集”的两个下拉列表中分别选中要合并的两个表，单击“合并”按钮即可。


3.10 添加地形

该功能主要是添加地形数据到程序中。

具体操作步骤如下图所示：

单击“文件”—“添加地形”，会弹出如下图所示的窗体：

选中要添加的地形数据，单击“打开”按钮即可。


3.11 新建数据

该功能主要是新建一个空图层。

具体操作步骤如下图所示：

单击“文件”—“新建数据”，会弹出如下图所示的窗体：

选择新建数据要保存的位置，填写文件名和选择保存类型，单击“保存”按钮即可，程序会自动在指定目录生成文件并添加到程序中。


3.12 保存所有数据

该功能主要是保存用户对程序中数据的修改。

具体操作步骤如下图所示：

单击“文件”—“保存所有数据”即可。


3.13 Shp2KML、LGD

该功能主要是将.shp格式的数据转换为.kml或者.lgd格式的数据。

具体操作步骤如下图所示：

单击“文件”—“Shp2KML、LGD”，会弹出如下图所示的窗体：

在“shapefile图层”标签后面的下拉列表中选择一个.shp格式的数据，在“LGD、KML文件”标签后面的文本框中输入或者单击“...”按钮选择一个路径，单击“转换”按钮即可。

“标注字段”标签后面的下拉列表是用来选择一个字段作为标注信息的；

“导出字段”标签后面的列表是用来选择要导出到新图层中的字段。


3.14 框选导出图层

该功能主要是用户将指定的图层中 用户所画的面对象圈定的要素导出成一个图层。

具体操作步骤如下图所示：

首先使用“工具”—“绘制面”功能，绘制一个面，也可以绘制多个面，这些面要圈住你需要导出的要素；

使用“工具”—“选中对象”功能选中这些面；

单击“文件”—“框选导出图层”，会弹出如下图所示的窗体：

在“导出图层的名称”标签后面的下拉列表中选择要导出的图层，然后单击“选择导出路径”按钮选择导出的图层文件的存放路径，单击“确定”按钮即可。


3.15 lgd、kml合并

该功能主要是将.lgd和.kml格式的数据合并成一种格式如.lgd或者.kml格式的数据。

具体操作步骤如下图所示：

单击“文件”—“lgd、kml合并”，会弹出如下图所示的窗体：

单击“选择lgd文件”按钮选择一个.lgd或者.kml格式的文件，单击“选择kml文件”按钮选择一个.kml或者.lgd格式的文件，单击“保存路径”按钮选择文件的名称和保存路径，单击“合并”按钮即可。


3.16 退出

该功能主要是直接从程序中退出。

具体操作步骤如下图所示：

单击“文件”—“退出”，会弹出如下图所示的窗体：

单击“是”按钮程序会自动将球中的数据进行保存，然后退出程序；单击“否”按钮，程序会直接退出程序，不保存用户对数据的修改；单击“取消”按钮，程序不退出，回到原来的界面。


4.视图

本节主要讲的是界面上的一些设置，如大气层、经纬网、状态条、控制面板、工具条等等。


4.1 大气层

该功能主要是控制三维球中大气层的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“大气层”即可。

下图是大气层显示与隐藏时候的图片：

显示：

隐藏：


4.2 经纬网

该功能主要是控制三维球中经纬网格的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“经纬网”即可。

下图是经纬网显示与隐藏时候的图片：

显示：

隐藏：


4.3 状态条

该功能主要是控制三维球中状态条的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“状态条”即可。

下图是状态条显示与隐藏时候的图片：

显示：

隐藏：


4.4 控制面板

该功能主要是控制三维球中控制面板的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“控制面板”即可。

下图是控制面板显示与隐藏时候的图片：

显示：

隐藏：


4.5 工具条

该功能主要是控制三维球中工具栏的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“工具条”即可。

下图是工具条显示与隐藏时候的图片：

显示：

隐藏：


4.6 大理石表面

该功能主要是控制三维球中大理石表面的显示和隐藏。

具体操作步骤如下图所示：

单击“视图”—“大气层”即可。

下图是大气层显示与隐藏时候的图片：

显示：

隐藏：


4.7 显示全球

该功能主要是可以直接跳转到可以看到整个三维球的状态。

具体操作步骤如下图所示：

单击“视图”—“显示全球”即可。

下图是单击后视图窗口中球返回的位置的图片：


4.8 全屏显示

该功能主要是控制三维球的全屏显示。

具体操作步骤如下图所示：

单击“视图”—“全屏显示”即可。

下图是全屏显示时候的图片：


5.编辑

本节主要讲的是对图层、管线以及模型进行添加、编辑、删除等操作。


5.1 前进

该功能主要是对用户所做过的操作而言的，如果你后退过，那么单击“前进”按钮可以回到后一步的操作。


5.2 后退

该功能主要是对用户所做过的操作而言的，可以向后退一步，回到前一步的操作。


5.3 添加对象

该功能包括三个字功能，分别是添加标注、添加模型、批量添加模型。


5.3.1 添加标注

该功能是在图层中添加标注信息。

具体操作步骤如下所示：

单击“编辑”—“添加对象”—“添加标注”，弹出如下图所示窗体：

用户可以对标注的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的标注，如下图所示：


5.3.2 添加模型

该功能是在图层中添加模型（*.gcm、*.3ds）。

具体操作步骤如下所示：

单击“编辑”—“添加对象”—“添加模型”，弹出如下图所示窗体：

单击“选择”按钮选择一个模型文件，单击“确定”按钮即可在界面中看到如下图所示界面：

如果你没有看到模型，那可能是因为高度的原因 ，在左侧节点树的“我的地标”节点下找到你添加的模型，如下图所示：

双击“我的模型”节点，即可飞行到模型所在位置。


5.3.3 批量添加模型

该功能是在图层中添加多个模型（*.gcm、*.3ds）。

具体操作步骤如下所示：

单击“编辑”—“添加对象”—“添加模型”，弹出如下图所示窗体：

单击“源数据路径”按钮选择一个包含模型的文件夹，单击“确定”按钮即可。

如果看不到模型，那可能是文件夹中没有模型，或者是因为高度的原因没看到。你可以看看左侧节点树“我的地标”节点下面是否生成了新的节点，如果有新的节点，双击节点即可飞行到模型所在位置，如果没有新的节点，那就是选择的文件夹下没有模型文件。


5.4 种树

该功能主要是实现用户添加模型的连续操作，用户选择一个模型之后，在选中对象状态下，可通过单击鼠标左键在鼠标单击的地方添加一个模型。

具体操作步骤如下所示：

单击“编辑”—“种树”，会弹出如下图所示窗体：

单击“浏览”按钮选择一个包含模型的文件夹，如果所选文件夹下包含模型文件，程序会自动将模型添加到“浏览”按钮下方的列表中，选中一个模型，可以在窗体下方的控件中对模型进行浏览，如下图所示：

当选好模型之后，单击“工具”—“选中对象”，之后鼠标左键单击你想要添加模型的位置，程序就会自动在你鼠标单击的位置添加一个模型，如下图所示：

如果你想换一个模型，在列表中选中要添加的模型，重复上述操作即可。

添加完成之后，关闭窗体即可。


5.5 添加动态对象

该功能主要是用来添加动态的对象，如喷泉、动态的图标、烟火、火苗、烟画、水柱等。


5.5.1 喷泉

该功能是在图层中添加喷泉对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“喷泉”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.5.2 动态标注

该功能是在图层中添加动态标注。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“动态标注”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.5.3 烟火

该功能是在图层中添加烟火对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“烟火”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.5.4 火苗

该功能是在图层中添加火苗对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“火苗”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.5.5 烟花

该功能是在图层中添加烟花对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“烟花”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.5.6 水柱

该功能是在图层中添加水柱对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“水柱”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置（也可以不设置），设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6 添加几何对象

该功能主要是用来添加几何对象，如长方形、圆、柱、缺口椭圆等等。


5.6.1 长方体

该功能是在图层中添加长方体对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“长方体”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.2 球

该功能是在图层中添加球对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“球”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.3 柱

该功能是在图层中添加柱对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“柱”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.4 台

该功能是在图层中添加台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.5 管

该功能是在图层中添加管对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“管”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.6 管台

该功能是在图层中添加管台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“管台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.7 椭球

该功能是在图层中添加椭球对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“椭球”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.8 椭圆柱

该功能是在图层中添加椭圆柱对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“椭圆柱”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.9 椭圆台

该功能是在图层中添加椭圆台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“椭圆台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.10 椭圆管

该功能是在图层中添加椭圆管对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“椭圆管”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.11 椭圆管台

该功能是在图层中添加椭圆管台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“椭圆管台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.12 缺口椭球

该功能是在图层中添加缺口椭球对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“缺口椭球”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.13 缺口椭圆柱

该功能是在图层中添加缺口椭圆柱对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“缺口椭圆柱”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.14 缺口椭圆台

该功能是在图层中添加缺口椭圆台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“缺口椭圆台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.15 缺口椭圆管

该功能是在图层中添加缺口椭圆管对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“缺口椭圆管”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.6.16 缺口椭圆管台

该功能是在图层中添加缺口椭圆管台对象。

具体操作步骤如下所示：

单击“编辑”—“添加动态对象”—“缺口椭圆管台”，弹出如下图所示窗体：

用户可以对该动态对象的属性进行设置，设置之后，单击“确定”按钮即可在界面上看到添加的动态对象，如下图所示：


5.7 平移模型图层

该功能主要是用来调整模型图层的水平位置的。

具体操作步骤如下所示：

单击“编辑”—“平移模型图层”，弹出如下图所示窗体：

在“图层”标签后面的下拉列表中选择你要平移的图层，单击“起点”单选框，在视图窗口中用鼠标左键单击选择原始的经纬度，单击“目标点”单选框，在视图窗口中用鼠标左键单击选择目标点的经纬度，如下图所示：

当然你也可以手动输入原始经纬度和目标点经纬度，然后单击“平移”按钮即可。


5.8 抬升模型图层

该功能主要是用来调整模型图层的上下位置的。

具体操作步骤如下所示：

单击“编辑”—“平移模型图层”，弹出如下图所示窗体：

在“图层名称”标签后面的下拉列表中选择你要抬升的图层，在“升降高差”标签后面的文本框中输入你要抬升的高度，单击“应用”按钮即可。


5.9 框选删除

该功能主要是用来批量删除目标图层中的要素。

具体操作步骤如下所示：

首先将你要删除的要素所在的图层设置为目标图层，

单击“编辑”—“框选删除”，

绘制一个面，这个面圈住你要删除的要素，双击结束即可。


5.10 对象标注

该功能主要是用来给对象添加标注信息的。

具体操作步骤如下所示：

首先选中你要添加标注的要素，

单击“编辑”—“对象标注”，弹出如下图所示窗体：

设置标注的属性，和标注文本，单击“确定”按钮即可。添加标注后如下图所示：


5.11 线转管道模型

该功能主要是用来将线对象转换为管道模型。

具体操作步骤如下所示：

首先选中你要添加标注的要素，

单击“编辑”—“线转管道模型”，弹出如下图所示窗体：

在“shapefile图层”标签后面的下拉列表中选择你要转换的图层，单击“kml文件”标签后面的“...”按钮选择一个路径，设置管道的属性，单击“建模”按钮即可。


5.12 批量添加模型

该功能主要是用来给点图层批量添加模型的。

具体操作步骤如下所示：

单击“编辑”—“批量添加模型”，弹出如下图所示窗体：

在“选择点图层”标签后面的下拉列表中选择一个图层，单击“模型路径”标签后面的“...”按钮选择一个模型文件，单击“图层保存路径”标签后面的“...”按钮选择一个路径，单击“确定”按钮即可。


5.13 批量生成管孔

该功能主要是用来批量生成管孔的。

具体操作步骤如下所示：

单击“编辑”—“批量生成管孔”，弹出如下图所示窗体：

在“shapefile图层”标签后面的下拉列表中选择你要转换的图层，单击“管线模型文件”标签后面的“...”按钮选择一个路径，设置管孔的属性，单击“建模”按钮即可。


5.14 新建数据库数据集

该功能主要是在数据库中创建空要素数据表。

具体操作步骤如下所示：

单击“编辑”—“新建数据库数据集”，弹出如下图所示窗体：

在“模板Shp图层”标签后面的下拉列表中选择你要创建的要素类的模板，在“新图层名称”标签后面的文本框中输入要素类的名称，单击“建模”按钮即可。


5.15 复制数据库要素集结构

该功能主要是在数据库中创建有表结构但是数据为空的数据表。

具体操作步骤如下所示：

单击“编辑”—“复制数据库要素集结构”，弹出如下图所示窗体：

在“数据库模板图层”标签后面的下拉列表中选择你要创建的要素集的模板，在“新图层名称”标签后面的文本框中输入要素类的名称，单击“创建”按钮即可。


6.工具

本节主要讲的是对图层、管线的浏览操作以及自定义对象的操作，如浏览对象、选中对象、平移对象、缩放对象、升降对象、旋转对象、绘制线、绘制面、绘制水面、投影等操作。


6.1 浏览对象

该功能主要是对视图窗口中的数据、影像、模型进行浏览。

具体操作步骤如下所示：

单击“工具”—“浏览对象”即可。


6.2 选中对象

该功能是对数据进行选择，用来提供数据的编辑、删除、分析等操作。

具体操作步骤如下所示：

单击“工具”—“选中对象”，在图层中鼠标左键单击对象即可。


6.3 缩放对象

该功能主要是对视图窗口中的数据、影像、模型进行缩放。

具体操作步骤如下所示：

单击“工具”—“缩放对象”，在图层中拖动选中对象缩放到指定大小。


6.4 旋转对象

该功能的主要功能是对管线或者模型选中对象进行旋转操作。

具体操作步骤如下所示：

单击“工具”—“旋转对象”，在图层中拖动选中对象旋转到指定位置。

图5－7旋转对象


6.5 平移对象

该功能的主要功能是对管线或者模型选中对象进行平移操作。

具体操作步骤如下所示：

单击“工具”—“平移对象”，在图层中拖动选中对象平移到指定位置。

图5－5平移对象


6.6 升降对象

该功能的主要功能是对管线或者模型选中对象进行升降操作。

具体操作步骤如下所示：

单击“工具”—“升降对象”，在图层中拖动选中对象升降到指定位置。

图5－6升降对象


6.7 绘制线

该功能是在图层中实现画线功能，点击“工具”—“绘制线”，在图层中画线，双击结束。如下图所示：


6.8 绘制面

该功能是在图层中实现画面功能，点击“工具”—“绘制面”，在图层中画面，双击结束。如下图所示：


6.9 绘制水面

该功能是在图层中实现画水面功能，点击“工具”—“绘制水面”，在图层中画水面，双击结束。如下图所示：


6.10 投影

该功能主要是经纬度坐标和地方坐标之间的投影转换。

具体操作步骤如下所示：

单击“工具”—“投影”，弹出如下图所示窗体：

输入经纬度坐标，或者地方坐标，

如果需要经纬度坐标转化为地方坐标，在“经度”、“纬度”标签后面的文本框中输入坐标后点击“>>”，即可转换成对应的地方坐标横轴、纵轴；

如果是地方坐标转换为经纬度坐标，在“横轴”、“纵轴”标签后面的文本框中输入坐标值后点击“<<”，即可换转成对应的经纬度坐标值。


7.飞行

本节主要讲的是飞行的一些操作，如飞行到目标点、沿线飞行、绕中心点飞行、绕眼睛飞行等。


7.1 飞行到目标点

该功能主要是飞行到视图窗口中指定经纬度坐标的位置。

具体操作步骤如下所示：

单击“飞行”—“飞行到目标点”，弹出如下图所示窗体：

在“经度”标签后面的文本框中输入经度坐标值，在“纬度”标签后面的文本框中输入纬度坐标值，在“高度”标签后面的文本框中输入距地面的高度，单击“确定”按钮即可飞行到指定的位置。


7.2 快速沿线飞行

该功能主要是视角沿着用户指定的路径（也就是一条线）快速飞行。

具体操作步骤如下所示：

首先选中一条线，

单击“飞行”—“快速沿线飞行”即可。


7.3 中速沿线飞行

该功能主要是视角沿着用户指定的路径（也就是一条线）中速飞行。

具体操作步骤如下所示：

首先选中一条线，

单击“飞行”—“中速沿线飞行”即可。


7.3 慢速沿线飞行

该功能主要是视角沿着用户指定的路径（也就是一条线）慢速飞行。

具体操作步骤如下所示：

首先选中一条线，

单击“飞行”—“慢速沿线飞行”即可。


7.4 自定义沿线飞行

该功能主要是视角沿着用户指定的路径（也就是一条线）和用户设置的速度飞行。

具体操作步骤如下所示：

首先选中一条线，

单击“飞行”—“快速沿线飞行”，弹出一个窗体，如下图所示：

设置飞行高度、速度、拐弯速度之后，单击“确定”按钮即可。


7.5 绕中心点飞行

该功能主要是球沿着视图窗口的中心点转动。

具体操作步骤如下所示：

单击“飞行”—“绕中心点飞行”即可。


7.6 绕眼睛飞行

该功能主要是球沿着视图窗口的视角转动。

具体操作步骤如下所示：

单击“飞行”—“绕眼睛飞行”即可。


7.7 暂停飞行

该功能主要是暂停球的飞行。

具体操作步骤如下所示：

单击“飞行”—“暂停飞行”即可。


7.8 继续飞行

该功能主要是将暂停的飞行继续执行下去。

具体操作步骤如下所示：

单击“飞行”—“继续飞行”即可。


8.设置

本节主要讲的是对系统界面的一些设置，如浮动的一些设置、高程的缩放、场景光照的设置、地面透明度的设置、模型显示模式的设置、选择层次的设置等等。


8.1 允许浮动事件

该功能主要是允许球浮动。

具体操作步骤如下所示：

单击“设置”—“允许浮动事件”即可。


8.2 允许浮动高亮

该功能主要是允许浮动时高亮。

具体操作步骤如下所示：

单击“设置”—“允许浮动高亮”即可。


8.3 允许二维对象浮动提示

该功能主要是允许二维对象浮动提示。

具体操作步骤如下所示：

单击“设置”—“允许二维对象浮动提示”即可。


8.4 禁止鼠标浏览

该功能主要是禁止掉鼠标的浏览对象功能。

具体操作步骤如下所示：

单击“设置”—“禁止鼠标浏览”即可。


8.5 设置高程缩放

该功能主要是设置地形拉伸。

具体操作步骤如下所示：

单击“设置”—“允许高程缩放”弹出如下图所示窗体：

在“拉伸倍数”标签后面的文本框中输入你想要拉伸的倍数，单击“确定”按钮即可。

拉伸倍数为1时，是原来大小；拉伸倍数是3时，地形放大3倍。


8.6 场景光照设置

该功能主要是设置场景的光照。

具体操作步骤如下所示：

单击“设置”—“场景光照设置”，弹出如下图所示窗体：

对光照进行设置之后，单击“确定”按钮即可。


8.7 地面透明度设置

该功能主要是设置地面的透明度。

具体操作步骤如下所示：

单击“设置”—“地面透明度设置”，弹出如下图所示窗体：

拖动滑动条即可，也可以手动在滑动条后面的文本框中输入值。滑动条显示的值是透明度百分比（0—100）。


8.8 地下网格设置

该功能主要是设置地下网格的高度。

具体操作步骤如下所示：

单击“设置”—“地下网格设置”，弹出如下图所示窗体：

在“高度”标签后面的文本框中输入值，单击“应用”按钮即可。用户输入的值代表距地面的高度。


8.9 锁定地下浏览

该功能主要是当相机处于地下模式的时候，相机无法处于地面之上。

具体操作步骤如下所示：

单击“设置”—“锁定地下浏览”即可。


8.10 启用反走样

该功能主要是放置模型走样。

具体操作步骤如下所示：

单击“设置”—“启用反走样”即可。


8.11 启用光影大气

该功能主要是启用光影大气。

具体操作步骤如下所示：

单击“设置”—“启用光影大气”即可。


8.12 编辑时捕捉到物体

该功能主要是编辑模型时可以捕捉到模型。

具体操作步骤如下所示：

单击“设置”—“编辑时捕捉到物体”即可。


8.13 模型线框模式

该功能主要是模型显示为线框模式。

具体操作步骤如下所示：

单击“设置”—“模型线框模式”即可。


8.14 模型实体模式

该功能主要是模型显示为实体模式。

具体操作步骤如下所示：

单击“设置”—“模型实体模式”即可。


8.15 模型纹理模式

该功能主要是模型显示为纹理模式。

具体操作步骤如下所示：

单击“设置”—“模型纹理模式”即可。


8.16 设置选择层次

该功能主要是设置选择的层次。


8.16.1 选择第一层对象

该功能主要是设置选择的层次为第一层对象。

具体操作步骤如下所示：

单击“设置”—“设置选择层次”—“选择第一层对象”即可。


8.16.2 选择第二层对象

该功能主要是设置选择的层次为第二层对象。

具体操作步骤如下所示：

单击“设置”—“设置选择层次”—“选择第二层对象”即可。


8.16.3 选择第三层对象

该功能主要是设置选择的层次为第三层对象。

具体操作步骤如下所示：

单击“设置”—“设置选择层次”—“选择第三层对象”即可。


8.16.4 指定选择层次

该功能主要是设置选择的层次为指定层次的对象。

具体操作步骤如下所示：

单击“设置”—“设置选择层次”—“指定选择层次”，弹出如下图所示窗体：

在“选择层次”标签后面的文本框中输入你想要选择对象所在的层次，单击“确定”按钮即可。


9.相机

本节主要讲的是根据相机的位置不同，界面查看模式分为了三种，分别是浏览模式、行走模式、地下模式。


9.1 浏览模式

该功能主要是对地面对象的浏览。

具体操作步骤如下所示：

单击“相机”—“浏览模式”即可。


9.2 行走模式

该功能主要是通过键盘上的方向键对地面对象的进行浏览。

具体操作步骤如下所示：

单击“相机”—“行走模式”即可。此模式无法使用鼠标对地面对象进行浏览，只能使用键盘上的方向键对地面对象进行浏览。


9.3 地下模式

该功能主要是对地下部分数据的浏览，主要用做对地下三维管线的浏览查看。

具体操作步骤如下所示：

单击“相机”—“地下模式”即可。


10. 分析

本节主要讲的是在三维球中可以进行的一些测量、两点之间是否可以看见即通视分析、剖面分析、挖坑的一些操作等。


10.1 平面距离量算

该功能主要是对平面区域内距离的测量显示。

具体操作步骤如下所示：

单击“分析”—“平面距离量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：


10.2 平面面积量算

该功能主要是对平面区域内面积的测量显示。

具体操作步骤如下所示：

单击“分析”—“平面面积量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：


10.3 距地面高度量算

该功能主要是以地面作为起点的高度测量显示。

具体操作步骤如下所示：

单击“分析”—“平面面积量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：


10.4 空间距离量算

该功能主要是在空间任意区域内的距离测量显示。

具体操作步骤如下所示：

单击“分析”—“空间距离量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：


10.5 空间高度量算

该功能主要是可以从空间任意高度为起点的测量显示。

具体操作步骤如下所示：

单击“分析”—“空间高度量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：

图10-6 空间高度量算


10.6 空间面积量算

该功能主要是可以测量任意空间面积的大小。

具体操作步骤如下所示：

单击“分析”—“空间面积量算”即可在要测量的区域内进行测量，双击鼠标完成测量。如下图所示：


10.7 清除量算

该功能主要是对距离量算距离、高度、面积以及空间距离、空间高度、量算结果的清除。

具体操作步骤如下所示：

单击“分析”—“清除量算”即可。


10.8 空间通视分析

该功能主要是分析出两点在空间中是否可见。

具体操作如下所示：

单击“分析”—“空间通视分析”，以单击鼠标左键开始，在空间范围内进行通视分析，再次单击鼠标左键完成分析。其中，绿线部分表示可视，红线部分表示不可视，如下图所示：


10.9 可视域分析

该功能主要是分析指定半径的平面内是否可见。

具体操作步骤如下所示：

单击“分析”—“可视域分析”，以单击鼠标左键开始，在空间范围内进行可视域分析，再次单击鼠标左键完成分析。其中，绿线部分表示可视，黄线表示分析区域，如下图所示：


10.10 可视包络分析

该功能主要是分析指定半径的空间内是否可见。

具体操作步骤如下所示：

单击“分析”—“可视包络分析”，以单击鼠标左键开始，在空间范围内进行可视包络分析，再次单击鼠标左键完成分析。其中，绿线部分表示可视，如下图所示：


10.11 横断面分析

该功能主要是分析用户指定范围内的管线的横断面。

具体操作步骤如下所示：

单击“分析”—“横断面分析”，在视图窗口中绘制一条线，绘制线结束后弹出窗体，如下图所示：

单击管线的横断面（图中红色的圆圈），会在窗体下方的表格中显示管线的属性。


10.12 剖面分析

该功能主要是分析用户指定范围内的管线的剖面。

具体操作步骤如下所示：

单击“分析”—“剖面分析”，在视图窗口中绘制一条线，绘制线结束后弹出窗体，如下图所示：


10.13 填挖方分析

该功能主要是分析填挖方区域。

具体操作步骤如下所示：

单击“分析”—“填挖方分析”，在视图窗口中绘制一个面，绘制面结束后弹出窗体，如下图所示：

在“基准面高程”标签后面的文本框中输入高程值，单击“分析”按钮，用户绘制的面会发生变化，如下图所示：


10.14 基线剖面分析

该功能主要是基于一条线分析剖面。

具体操作步骤如下所示：

单击“分析”—“基线剖面分析”，在视图窗口中绘制一条线，绘制线结束后弹出窗体，如下图所示：

在“基准面高程”标签后面的文本框中输入高程值，单击“分析”按钮，窗体界面会发生变化，如下图所示：


10.15 无源淹没分析

该功能主要是分析出两点之间从最低点到最高点的淹没情况。

具体操作步骤如下所示：

单击“分析”—“无源淹没分析”，在视图窗口中绘制一个面，绘制面结束后弹出窗体，如下图所示：

单击“分析”按钮，窗体上方的文本框会自动生成用户绘制的面的一些数据，如下图所示：

单击“淹没演示”按钮，系统会根据用户设置的速度演示淹没的情况。


10.16 挖坑设置

该功能主要是对挖坑时的一些属性如挖坑值、挖坑宽度等等的设置。

具体操作步骤如下所示：

单击“分析”—“挖坑设置”，会弹出窗体，如下图所示：

对挖坑值、挖坑值模式、沿线挖坑宽度进行设置，单击“确定”按钮即可。


10.17 沿线挖坑

该功能主要是沿着用户绘制的线挖坑。

具体操作步骤如下所示：

单击“分析”—“沿线挖坑”，绘制一条线，系统会沿着线采用用户自定义的挖坑设置进行自动挖坑，如下图所示：


10.18 多边形挖坑

该功能主要是在一定区域范围内地面进行挖坑。

具体操作步骤如下所示：

单击“分析”—“多边形挖坑”，绘制一个多边形，以单击鼠标左键开始，双击鼠标左键结束，绘制完成后，系统会采用用户自定义的挖坑设置在鼠标选定范围内进行自动挖坑，如下图所示：


10.19 清除所有坑

该功能主要是清除所有坑。

具体操作步骤如下所示：

单击“分析”—“清除所有坑”即可。


10.20 刷新分析结果

该功能主要是刷新分析操作如空间通视分析等操作的结果。

具体操作步骤如下所示：

单击“分析”—“刷新分析结果”即可。


10.21 清除分析结果

该功能主要是清除分析操作如空间通视分析等操作的结果。

具体操作步骤如下所示：

单击“分析”—“清除分析结果”即可。


11. 管线

本节主要讲的是对管线的操作，如管线入库、管线对接、生成连接管、管线流向、创建拓扑、更改管线颜色、地上管线、管线碰撞分析、管线间距分析等等。


11.1 管孔方沟入库

该功能主要是将用户添加的.shp格式的图层以管孔方沟的形式导入数据库。

具体操作步骤如下所示：

单击“管线”—“管孔方沟入库”，弹出如下图所示窗体：

在“Shapefile图层”标签后面的下拉列表中选择一个.shp格式的图层，在“管线图层名称”标签后面的文本框中输入一个不存在的名字，设置属性字段，单击“建模”按钮即可。


11.2 工井入库

该功能主要是将用户添加的.shp格式的图层以工井的形式导入数据库。

具体操作步骤如下所示：

单击“管线”—“工井入库”，弹出如下图所示窗体：

在“图层文件”标签后面的下拉列表中选择一个.shp格式的图层文件，在“工井模型文件夹”标签后面的文本框中输入工井模型所在文件夹的路径或者单击“模型文件夹”按钮添加工井模型所在文件夹的路径，在“图层名称”标签后面的文本框中输入一个名称，设置属性字段，单击“确定”按钮即可。（注意窗体上方的提示）


11.3 雨水篦子入库

该功能主要是将用户添加的.shp格式的图层以雨水篦子的形式导入数据库。

具体操作步骤如下所示：

单击“管线”—“雨水篦子入库”，弹出如下图所示窗体：

在“图层文件”标签后面的下拉列表中选择一个.shp格式的图层文件，在“工井模型文件夹”标签后面的文本框中输入工井模型所在文件夹的路径或者单击“模型文件夹”按钮添加工井模型所在文件夹的路径，在“图层名称”标签后面的文本框中输入一个名称，设置属性字段，单击“确定”按钮即可。（注意窗体上方的提示）


11.4 阀门入库

该功能主要是将用户添加的.shp格式的图层以阀门的形式导入数据库。

具体操作步骤如下所示：

单击“管线”—“阀门入库”，弹出如下图所示窗体：

在“图层文件”标签后面的下拉列表中选择一个.shp格式的图层文件，在“图层名称”标签后面的文本框中输入一个名称，设置属性字段，单击“确定”按钮即可。


11.5 添加管件

该功能主要是根据国家规定行业标准，在图层中添加管件，如各类型型号阀门。

具体操作步骤如下所示：

单击“管线”—“添加管件”，在指定位置单击鼠标，弹出如下图所示窗体：

选中要添加的管线类型和管件规格，点击“添加”按钮即可。


11.6 管线对接设置

该功能主要是设置管线对接时的容差。

具体操作步骤如下所示：

单击“管线”—“管线对接设置”，弹出如下图所示窗体：

在“对接容差”标签后面的文本框中输入一个代表容差的数值，单击“确定”按钮即可。


11.7 对接选中管线

该功能主要是将两根管线对接到一起。

具体操作步骤如下所示：

首先选中两个管线，

然后单击“管线”—“对接选中管线”即可。


11.8 管线图层自动对接

该功能主要是将指定图层中的所有管线对接到一起。

具体操作步骤如下所示：

然后单击“管线”—“管线图层自动对接”，弹出如下图所示窗体：

在“图层名称”标签后面的下拉列表中选则要自动对接的管线图层，单击“处理”按钮即可。


11.9 生成连接管

该功能主要是在选中的两根管线直接添加一个连接管将两根管线连接到一起。

具体操作步骤如下所示：

首先选中两个管线，

然后单击“管线”—“生成连接管”即可。


11.10 选中节点添加模型

该功能主要是根据国家规定行业标准，在图层中指定节点处添加模型。

具体操作步骤如下所示：

单击“管线”—“选中节点添加模型”，在指定位置单击鼠标左键，弹出如下图所示窗体：

选中要添加的管线类型和管件规格，点击“添加”按钮即可。


11.11 取消选中对接

该功能主要是取消选中管线之间的对接。

具体操作步骤如下所示：

首先选中两个管线，

然后单击“管线”—“取消选中对接”即可。


11.12 取消整个图层对接

该功能主要是取消整个图层中的管线之间的对接。

具体操作步骤如下所示：

单击“管线”—“取消整个图层对接”，弹出如下图所示的窗体：

在“图层名称”标签后面的下拉列表中选则要自动对接的管线图层，单击“处理”按钮即可。


11.13 批量生成管沟

该功能主要是将指定.shp格式的图层中的数据导入一个新的管沟图层中。

具体操作步骤如下所示：

单击“管线”—“批量生成管沟”，弹出如下图所示的窗体：

在“ShapeFile图层”标签后面的下拉列表中选择一个.shp格式的图层文件，在“管线模型文件”标签后面的文本框中输入一个路径或者单击“...”按钮像文本框中添加一个路径，设置属性字段，单击“建模”按钮即可。


11.14 管线导入数据库

该功能主要是将管线数据导入数据库。

具体操作步骤如下所示：

单击“管线”—“管线导入数据库”，弹出如下图所示的窗体：

在“Shapefile图层”标签后面的下拉列表中选择一个.shp格式的图层，在“管线图层名称”标签后面的文本框中输入一个不存在的名字，设置属性字段，单击“建模”按钮即可。


11.15 排水入库

该功能主要是将排水类型的管线数据导入数据库。

具体操作步骤如下所示：

单击“管线”—“排水入库”，弹出如下图所示的窗体：

在“Shapefile图层”标签后面的下拉列表中选择一个.shp格式的图层，在“管线图层名称”标签后面的文本框中输入一个不存在的名字，设置属性字段，单击“建模”按钮即可。


11.16 创建拓扑

该功能主要是对图层创建拓扑。

具体操作步骤如下所示：

单击“管线”—“创建拓扑”，弹出如下图所示窗体：

在“选择线图层”中的下拉列表中选择一个图层，在“拓扑数据存入数据源”中选择一个数据库，设置参数，在“拓扑数据名称”标签后面的文本框中输入拓扑的名称，单击“确定”按钮即可。


11.17 流向显示

该功能主要是将指定图层中管线的流向用箭头显示出来。

具体操作步骤如下所示：

单击“管线”—“流向显示”，弹出如下图所示窗体：

在“请选择管线数据库图层”标签后面的下拉列表中选择一个数据库图层，单击“确定”即可。（复选框显示流向要选中），

下面是单击“确定”按钮之后的效果图：


11.18 更改图层中要素的名字

该功能主要是用图层中要素的任意一个属性字段来给要素命名。

具体操作步骤如下所示：

单击“管线”—“更改图层中要素的名字”，弹出如下图所示窗体：

在“请选择图层”标签后面的下拉列表中选择你要修改图层中要素名称的图层，在“请在下面的列表框中选择一个作为名字的字段”标签下面的列表框中选中一个字段，单击“确定”按钮即可。下面是效果图：

更改之前图层中要素的名称，如下图所示：

更改之后图层要素的名称如下图所示：

如果你单击“确定”按钮之后，左侧列表没有改变，那么，请右键，单击“刷新列表”按钮即可。


11.19 更改管线的颜色

该功能主要是更改指定图层中部分或者全部管线的颜色。

具体操作步骤如下所示：

单击“管线”—“更改管线的颜色”，弹出如下图所示窗体：

在“请选择图层”标签后面的下拉列表中选择你要修改管线颜色的图层，单击“管线颜色”标签后面的按钮选择一个你需要的颜色，

如果你想更改图层中所有管线的颜色，那么直接单击“确定”按钮即可；

如果你想更改图层中部分管线的颜色，那么选中“颜色”中的“部分管线”复选框，然后在“字段”中拼写sql查询语句，单击“确定”按钮即可。

下面是效果图：

更改管线颜色之前图层中管线的颜色如下图所示：

更改管线颜色之后图层中管线的颜色如下图所示：


11.20 查看管线属性

该功能主要是将选中管线的字段名和字段值形成一个列表显示出来。

具体操作步骤如下所示：

首先选中一条管线，

然后单击“管线”—“查看管线属性”即可。


11.21 反转管线流向

该功能主要是将管线的流像反转。

具体操作步骤如下所示：

首先选中一条管线，

单击“管线”—“反转管线流向”即可。


11.22 选中管线缩进接头

该功能主要是将选中管线的接头缩进。

具体操作步骤如下所示：

首先选中一条管线，

单击“管线”—“管线接头缩进”，弹出如下图所示窗体：

选中复选框“头部缩进”，在复选框“头部缩进”后面的文本框中输入要缩进的值，

选中复选框“尾部缩进”，在复选框“尾部缩进”后面的文本框中输入要缩进的值，

单击“确定”按钮即可。下图是缩进之后的效果图：


11.23 管线高级查询

该功能主要是根据用户的查询条件将符号用户查询条件的管线用一个列表显示出来。

具体操作步骤如下所示：

单击“管线”—“管线高级查询”，弹出如下图所示窗体：

在“请选择图层”标签后面的下拉列表中选择一个图层，然后在“字段”中拼写sql语句的查询条件，单击“确定”按钮即可。


11.24 地上管线

该功能主要是查询出图层中露出地面的管线。

具体操作步骤如下所示：

单击“管线”—“地上管线”，弹出如下图所示窗体：

在“管线类型”标签后面的下拉列表中选择一个图层，单击“确定”按钮即可。如果有地上管线，程序会直接将所有地上管线形成一个列表显示在窗体下方的列表框中。


11.25管线碰撞分析

该功能主要是分析图层中的管线有没有发生碰撞的管线。

具体操作步骤如下所示：

单击“管线”—“碰撞管线分析”，弹出如下图所示窗体：

在“请选择图层”标签下面的列表框中选中你要分析的图层，单击“确定”按钮即可。如果有发生碰撞的管线，程序会将所有发生碰撞的管线形成一个列表显示在窗体下方的列表框中。


11.26管线间距分析

该功能主要是分析两根管线之间的距离。

具体操作步骤如下所示：

首先选中两根管线，

然后单击“管线”—“管线间距分析”即可。


12. 拓扑

本节主要讲的是对于拓扑的一些操作，如线图层创建拓扑、连通分析、关阀分析、上下游追踪等等。


12.1 线图层创建拓扑

该功能主要是对图层创建拓扑。

具体操作步骤如下所示：

单击“拓扑”—“线图层创建拓扑”，弹出如下图所示窗体：

在“选择线图层”中的下拉列表中选择一个图层，在“拓扑数据存入数据源”中选择一个数据库，设置参数，在“拓扑数据名称”标签后面的文本框中输入拓扑的名称，单击“确定”按钮即可。


12.2 拓扑数据添加阀门信息

该功能主要是为拓扑数据添加阀门信息。

具体操作步骤如下所示：

单击“拓扑”—“拓扑数据添加阀门信息”，弹出如下图所示窗体：

在“选择数据源”中的下拉列表中选择一个数据库，在“选择拓扑数据集”中选择数据库中的一张拓扑表，在“选择进行匹配的图层” 中的下拉列表中选择一个图层，也就是数据库中的普通表，设置参数，单击“确定”按钮即可。


12.3 连通分析

该功能主要用来判断同一类型管线中的选定的两根管线是否连通。

具体操作步骤如下所示：

首先在同一类型管线中选择两根管线，

单击“拓扑”—“连通分析”，如果俩者连通，则显示流向，如果不连通则弹出提示信息。分析完成后，鼠标单击“连通性分析”关闭分析显示效果。如下图所示：

管线不连通

连通性分析显示效果


12.4 关阀分析

该功能主要用来判断同一类型管线中的选定的选定一根管线所对应的阀门位置，当该管线发生爆管，可找到控制该管线的阀门位置，将其关闭。

具体操作步骤如下所示：

首先在同一类型管线中选择一根管线，

单击“拓扑”—“关阀分析”，程序会自动追踪定位该管线所对应的阀门位置。如下图所示：

图8-6 阀门分析


12.5 上游追踪

该功能主要用来判断同一类型管线中对选中的一条管线，显示所有流向该管线的显示操作。

具体操作步骤如下所示：

首先在同一类型管线中选择一根管线，

单击“拓扑”—“上游追踪”，即可显示所有上游经过该管线的管线的流向。如下图所示：

图8-11 上游追踪


12.6 下游追踪

该功能主要用来判断同一类型管线中对选中的一条管线，显示所有流向该管线的显示操作。

具体操作步骤如下所示：

首先在同一类型管线中选择一根管线，

单击“拓扑”—“下游追踪”，即可显示所有下游经过该管线的管线的流向。如下图所示：

图8-12下游追踪


12.7 清除追踪结果

该功能主要清除上、下游追踪的结果。

具体操作步骤如下所示：

单击“拓扑”—“清除追踪结果”即可。


12.8 清除关阀分析结果

该功能主要清除关阀分析的结果。

具体操作步骤如下所示：

单击“拓扑”—“清除关阀分析结果”即可。


13. 关于

本节主要讲的是本系统的名称、版本、摘要等一些基本信息和帮助文档的调用。


13.1 关于我们

该功能主要是显示软件的基本信息。

具体操作步骤如下所示：

单击“关于”—“关于我们”，弹出如下图所示窗体：


13.2 帮助文档

该功能主要是打开帮助文档。

具体操作步骤如下所示：

单击“关于”—“帮助文档”，会打开如下图所示帮助文档：